Brugtgrej.dk
Forside  |   Ny annonce  |   Forum  |   Nyhedsmails  |   Støt brugtgrej  |   Kontakt Brugtgrej
124 online brugere
3054 online annoncer
SælgesKøbes

http - med og uden s

Denne tråd er lukket for nye indlæg

#1  16/11-16 22:03
søren/oz4zat
Indlæg: 522
Når man indsætter en link opfatter BGs software det som en almindelig tekst og klikbarheden forsvinder - f.eks. her:
https://da.wikipedia.org/wiki/Hertz#Historisk
Hvis man fjerner "s" i "https" så får man dette:
http://da.wikipedia.org/wiki/Hertz#Historisk
mvh
søren

----------
færdes også på http://rdeforum.dk

Redigeret 17/11-16 14:41
#2  16/11-16 22:56
Gert Mandrup, OZ4ZG

Indlæg: 354
Svar til #1:
- - -

Redigeret 17/11-16 19:35
#3  16/11-16 23:08
Jens Sigurdson

Indlæg: 947
Svar til #1:
Det var måske en ting Brugtgrej burde få rettet. Det er ikke altid lige heldigt at komme afsted uden s'et hvis det f.eks.er en handelsside.

----------
Hilsen
Jens

#4  17/11-16 00:16
Allan 1

Indlæg: 2110
Jeg mener nu ikke, at det er BGs software alene, der er årsag til problemet.
Det er derimod selve HTTP-protokollen, der volder problemet, idet https ikke af alle browsere (om nogen?) automatisk opfattes som en link. Det gør derimod http.

En anden del af problemet ligger i, at BG samt snart alle mulige andre forbindelser mellem klient og server nu til dags oprettes som https forbindelse, som er den krypterede udgave af http.
Oprindeligt var det ikke muligt at videregive en https link til andre computere, men det er det nu, idet nogle browsere automatisk fjerner s i https, og forbindelsen oprettes som en http, som derefter forhandles til en https forbindelse, så vidt jeg har kunnet orientere mig.

BG kan imidlertid godt gøre noget. Der kan indføres mulighed for at markere det, som skal opfattes som en link, og derved definere det som en link. Jeg har dog ikke den helt store opfattelse af, at det løser problemet, idet mange brugere simpelthen vil "overse" denne mulighed. Og så er man lige vidt.
Jeg mener dog, at der kan findes eller udvikles programrutiner, til editering i forum´s, der automatisk løser problemet.. Jeg kan blot ikke umiddelbart huske, hvor jeg er stødt på det.

Jeg har ofte leget lidt med at finde en parallel til det gamle huskevers: "Den, der skriver d i gjort, han skal ha´ sin ende smurt", der kunne anvendes om s´et i https, men min fantasi eller poesi har indtil videre ikke rakt.
Måske nogle kan hjælpe?

Redigeret 17/11-16 00:56
#5  17/11-16 10:29
Gert Mandrup, OZ4ZG

Indlæg: 354
Svar til #4:
Vi kan jo ændre d remsen, til en positiv version :-)

Hvis du fjerner s i link, synes vi, du er ret så flink.

#6  17/11-16 11:32
Daniel Buch - OZ8AES

Indlæg: 56
Realt set drejer det sig om at browseren kigger på følgende porte i TCP-protokollen:
http = port 80
https = port 443

og når man bruger port 443 så forventer man at server kryptere trafikken.

/Daniel

#7  17/11-16 11:38
Søren N., 5Q5A

Indlæg: 306
Svar til #4:
Det lyder meget rigtigt, jeg er ikke superklog på det.

Hvis man selv gerne vil bruge https, så er der forskellige løsninger som gennemtvinger https når muligheden er der. F.eks. ovenstående link med http, bliver hos mig åbnet som https, så et eller andet sted er det for mig ikke så vigtigt.
Men har man ikke det, så er spørgsmålet vigtigt, og det ville da være bedst at der var en god løsning.

----------
5Q5A

#8  17/11-16 12:57
OZ1BV, Brian
Indlæg: 493
Svar til #1:
Hej Søren

Det er ganske enkelt fordi siden som lytter på http (port 80) foretager en viderestilling til https (port 443). Wikipedia ønsker at man kører krypteret (https) men det vil kræve at folk indtaster https:// foran URL'en da der ellers ikke vil kunne vises en side. Det løser man så elegant ved at viderestille http siden. (Nogle browsere er dog i stand til selv at forsøge https hvis http ikke svarer).
Konklusionen er, at det ikke er en farbar vej blot at angive http i stedet for https, desværre.

----------
Vy 73 de OZ1BV, Brian

#9  17/11-16 13:36
Gert Mandrup, OZ4ZG

Indlæg: 354
Svar til #1:
- - -

Redigeret 17/11-16 19:35
#10  17/11-16 14:41
søren/oz4zat
Indlæg: 522
Når jeg bragte emnet op er det fordi jeg antager, at den som lægger links op på BG er interesseret i at læserne benytter dem.
Indtil videre er jeg ikke stødt på links som ikke virkede når man fjerner det famøse "s".
Måske skal jeg skære det ud i pap:
Hvis du ønsker, at folk skal klikke på dine links så fjern "s"et i "https".
(I mange sammenhænge taler og skriver man om begrebet "læsevenlighed" - det gælder vel også DINE indlæg på BG ?)
mvh
søren

----------
færdes også på http://rdeforum.dk

Redigeret 17/11-16 14:42
#11  19/11-16 08:45
OZ5ES, Ebbe
Indlæg: 1015
Svar til #10:
Nu vi er ved det, så er der nogle, som tilføjer et punktum i enden af linket, det er en uvane ;-)

Mvh Ebbe

----------
Mvh Ebbe.

Denne tråd er lukket for nye indlæg